FAQ:

How do I build an rpm of galeon?

Answer:

Binary builds of galeon are depend on the exact version of mozilla that it was used to build against. If you are using an rpm based distro then you best option is to build the binary rpm yourself.

Download the source code then as root (or your prefered rpmbuild user) run "rpmbuild -tb galeon-<version>.tar.bz2". For this to work you must have the mozilla-devel rpm installed as well as the main rpm.

NOTE: Due to recent changes of which version of gtk was used to build mozilla you might have more luck using galeon-1.3.X rather than galeon-1.2.x

NOTE: If you're trying to build for Red Hat 9 or another gtk-2.2 based system, galeon-1.3.14 is the last compatible version.

DONE Successful Build Versions :

Distribution Mozilla Version Mozilla Distributor Galeon Version down
Fedora Core 2 1.7-0.2.0 Mozilla.org 1.3.16
Fedora Core 2 1.7.2-0.2.0 FC2 RPM 1.3.17
Fedora Core 2 1.7.3-0.2.0 FC2 RPM 1.3.17*
Fedora Core 2 1.7.3-0.2.0 FC2 RPM 1.3.18
Fedora Core 3 1.7.3-17 FC3 RPM 1.3.18**

* with the patch below:

=====================================
--- mozilla/mozilla-embed.cpp.broken    2004-09-25 11:16:34.895927837 +1000
+++ mozilla/mozilla-embed.cpp   2004-09-25 11:17:13.802160310 +1000
@@ -1388,7 +1388,8 @@
        rv = wrapper->ForceEncoding (charset);
        if (NS_FAILED (rv)) return G_FAILED;
 
-#if MOZILLA_CHECK_VERSION4 (1,8,MOZILLA_ALPHA,3)
+#if MOZILLA_CHECK_VERSION4 (1,8,MOZILLA_ALPHA,3) || \
+    (MOZILLA_IS_BRANCH (1,7) && MOZILLA_CHECK_VERSION3(1,7,3))
        gtk_moz_embed_reload (GTK_MOZ_EMBED (embed),
                              GTK_MOZ_EMBED_FLAG_RELOADCHARSETCHANGE);
 #else
=====================================

** Fedora Core 3, Test 3 with all the development updates up to 30 Oct 2004.

ALERT! Known Incompatible Versions :

Distribution Mozilla Version Mozilla Distributor Galeon Version
Fedora Core 2 1.7-0.2.0 Mozilla.org 1.2.14
Fedora Core 2 1.7-1.1.fc2.nr Matt Hall 1.2.14